Major AWS Outage causing disruption to multiple Cloud Services

Resolved

The incident has been resolved and all services are back to normal
Posted Oct 20, 2025 - 21:05 PDT

Update

We've started seeing continued product experience improvement.
Posted Oct 20, 2025 - 14:36 PDT

Update

We are continuing to monitor for any further issues.
Posted Oct 20, 2025 - 14:29 PDT

Monitoring

https://health.aws.amazon.com shows major AWS DNS outage affecting multiple services like login, MFA. HPE Networking team is monitoring the situation and will update the status once services are back to normal.
Posted Oct 20, 2025 - 03:08 PDT
This incident affected: Orchestrator As a Service (Orchestrator As a Service(Northern Virginia)), Orchestrator Service Provider (Orchestrator Service Provider(Northern Virginia)), and Orchestrator Global Enterprise (Orchestrator Global Enterprise(Northern Virginia)).